Routes remain in progress when drivers complete a route

Incident Report for moversystems

Resolved

🏁 Final Resolution 🏁

πŸ“ **High-level Cause Summary:** Some routes could not be completed from driver app.

πŸ•’ **Start Time:** 9:15 CPH

πŸ•’ **Finalization Time:** 10:10 CPH

πŸ”§ **Fix implemented:** N/A

πŸ›Ÿ **Preventive Measures:** Rollback latest release
Posted May 29, 2025 - 11:02 CEST

Update

🚨 Incident Update 🚨

πŸ“ **Issue:** When drivers completes a route in driver app, the route remains in status 'in progress'. Seems not be widespread.

πŸ™Žβ€β™‚οΈ **Customers impacted:** All customers

πŸ•’ **Start Time:** 9:25 CPH

πŸ“ˆ **Current Status:** No new incidents reported

πŸ‘· **Current Action:** Monitoring

🏁 **Expected resolution time:** 10:10 CPH

⏳ **Next Update:** 11:00 CPH
Posted May 29, 2025 - 10:27 CEST

Monitoring

🚨 Incident Update 🚨

πŸ“ **Issue:** When drivers completes a route in driver app, the route remains in status 'in progress'.

πŸ™Žβ€β™‚οΈ **Customers impacted:** All customers

πŸ•’ **Start Time:** 9:25 CPH

πŸ“ˆ **Current Status:** There is a manual workaround where a coworker can complete the route in TMS platform.

πŸ‘· **Current Action:** Change in route completion logic identified in release 2025-05-28. Release is rolled back.

🏁 **Expected resolution time:** 10:10 CPH

⏳ **Next Update:** 10:30 CPH
Posted May 29, 2025 - 10:09 CEST

Investigating

🚨 Incident Update 🚨

πŸ“ **Issue:** When drivers completes a route in driver app, the route remains in status 'in progress'.

πŸ™Žβ€β™‚οΈ **Customers impacted:** All customers

πŸ•’ **Start Time:** 9:25 CPH

πŸ“ˆ **Current Status:** There is a manual workaround where a coworker can complete the route in TMS platform.

πŸ‘· **Current Action:** Investigating logs and latest release to indetify root cause

🏁 **Expected resolution time:** N/A

⏳ **Next Update:** 15 min
Posted May 29, 2025 - 09:59 CEST
This incident affected: Route Execution.